
 
 

 
Five Year Forecast Training 

 
How to use the SSDT spreadsheet and report your 

forecast 
 

Created by: OME-RESA Staff along with excerpts from the SSDT’s forecast instructions.  
  



 2

Table of Contents: 
 

 
 
Introduction         1 
Downloading the SSDT Spreadsheet   2 
Spreadsheet Instructions     4 
Getting the USAS Data      5 
Downloading Files       6 
Entering/Correcting Data Manually   8 
Correcting Common Problems    9 
Exporting for use with EMIS     10 
Uploading the Forecast      10 
Notes to the forecast       11 
Uploading the Notes       12 
Getting Data into EMIS      13 
Resubmitting Forecast Data     15 
 



 1

Introduction 
 
 
 
This booklet will provide you with the instructions necessary to produce the five-
year forecast via the SSDT’s spreadsheet.  The following steps will be covered: 
 

1.) How to download the SSDT forecast from the web. 
 

2.) How to import data from your USAS files to the SSDT forecast 
spreadsheet. 

 
3.) How to upload the data in the forecast to the EMIS software for 

reporting purposes. 
 

4.) How to correct and resubmit your forecast data. 
 
At this time, there are several different methods by which you are able to produce 
and report your five-year forecast.  By no means are we intending to “push” the 
SSDT forecast spreadsheet by creating this training booklet over any other 
method you may choose.  However, because of the mass amount of options out 
there for creating the spreadsheet, we felt that we must select one and offer 
training for it as an option for those that are not comfortable with others.  Should 
you choose another spreadsheet, we will try to help as much as possible with it, 
but understand that our experience lies with the SSDT spreadsheet and we may 
not know the answers to your questions in other situations. 
 
 
With that said…  ☺…On to the five-year forecast! 
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Downloading the SSDT Forecast Spreadsheet 

 
To download the SSDT forecast, go to the following URL: 
 
http://dl.ssdt.oecn.k12.oh.us/ww2/ssdt/forecast/ 
 
Once the page loads, you will see the following: 
 
SSDT Five Year Financial Forecast 
 
Current Version: 2.01-3 
Revision Date: 20-Sep-1999 
 
New for FY2000: The SSDT spreadsheet now comes in two flavors:  
 
Standard:  Includes several optional sheets including "Presentage" and 
"Summary" presentations of the Forecast similar to ones provided by AOS.  Also 
included is a "Charts" sheet which contains several sample Excel charts showing 
graphical presentations of the forecast data.  These additional views and charts 
work without any additional effort and  update automatically when as the Forecast 
data is updated.  
      
Basic:   The basic sheet contains just what you need to import data from USAS 
and complete the forecast as required by SF and EMIS, without the extra fluff.  
We recommend this sheet if you have a slower PC/Mac without much memory, 
or if you just don't want to deal with anything "extra".  
 
Note: This spreadsheet was developed for OECN State Software users. 
However, the spreadsheet can function as stand-alone with data entered 
manually or imported from other sources. Therefore, non-state software users 
are welcome to download and use this spreadsheet.  
 
If you have questions, comments or suggestions regarding the spreadsheet or 
the USASFF program, please visit us in the "State Software: USAS" forum in the 
OECN Public Discussion Forums  
 
Download the desired spreadsheet by clicking the link below:  
 
     Standard Version for Excel 2000/97 or Excel 95  
     Basic Version for Excel 2000/97 or Excel 95  
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We are recommending the “Basic” version as this will accomplish what we are 
here to do.  ☺ 
 
Once you click on the “Basic” version download, take the option to save it to disk.  
You can save it wherever you want…just remember where you put it! 
 
The download is very quick and once it is complete…you can move on to the 
next step. 
 
 

Using the Spreadsheet 
 

Once the file is downloaded, you can close your web browser and go to the 
location on your pc where you stored the spreadsheet and open it by double 
clicking it.  A prompt will come up asking you to enable macros, click on that 
option to continue. 
 
The workbook will contain four sheets within it: 
 

1.) Instructions 
2.) Forecast 
3.) Parameters 
4.) Data 

 
The following is the “Instructions” portion of the workbook that will explain the use 
of the spreadsheet (created by SSDT).  We have included various “additions” to 
the instructions to tailor it more to your needs and to explain in a little more detail 
what you need to do. 
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Five Year Financial Forecast 
Spreadsheet 

   

Instructions       
        

 This spreadsheet was developed by the SSDT to assist 
school district's in preparing the Five Year Financial 
Forecast required by HB412 and EMIS. 
 
The spreadsheet may be used alone (by hand entering 
the values) or in conjunction with the USASFF program 
provided by the SSDT with the  USAS software.   The 
USASFF program provides a CSV file which can be 
imported into this spreadsheet to provide the three prior 
year actual values as well as the expendable/receivable 
values for the current year estimate. 
 
Note:  These instructions assume you are using Microsoft 
Excel 97 or Excel 2000.  The spreadsheet is believed to 
be compatible with earlier versions of Excel.  However, 
the precise steps may vary slightly if you are using a 
different spreadsheet application. 

Tip 
 
If you have questions or 
need assistance using this 
spreadsheet, visit the USAS 
forum on the  OECN Public 
Discussion forums at 
http://ssdt.oecn.k12.oh.us/fo
rums 
 
The Forums are a web-
based 'discussion' areas 
(similar to DEC Notes).  
Someone from the SSDT 
will be there to help you. 
 

        
Getting Started      

 This spreadsheet is actually a 'workbook" which contains multiple "worksheets".  You 
will need to switch between the various sheets while you prepare the forecast. You are 
currently viewing the "Instructions" worksheet.  Near the bottom of this window are tabs 
which allow you to switch between the various sheets.  You should see the following 
worksheets: 
 
- 'Instructions'  is the sheet you are currently viewing 
- 'Forecast' contains the Five Year Forecast 
- 'Parameters' contains global parameters (district's name, FY) 
- 'Data' may contain the information imported from USASFF. 
 
Now switch to the 'Parameters' sheet and enter your district's name, county and the 
fiscal year.  After you enter these values, switch to the 'Forecast' 
Sheet to see that your district name and fiscal year appear in the headings 
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Getting the USAS Data 
 
 
In order to bring in the data necessary for the forecast, you can do so (as shown 
on the next page) in one of two ways.  You can either import the data by running 
USASFF or by manual input. 
 
To run the USASFF program, you can do so by entering USASFF at the menu 
prompt on our system.  The following is a screen dump of the USASFF program: 
 
 
 
                            Five Year Forecast Report/Export                       
 
    Output Report USASFF.TXT           
    Detail or Summary? D 
 
 
  The following funds are automatically included by this module: 
 
    001, 002, 016, 455, 447 
 
  For fund 002 only expenditures and revenues for SCC 8001 are included 
  automatically.  Any other SCC's of Fund 002 are included if the 
 'Include on SM1/SM2' flag on the cash account record is set to 'Y'. 
 
    Source of projected amounts for current fiscal year A 
    (A)-USAS Accounts  (S)-SM1 amounts  (B)-Leave Blank 
 
 
                                                                                                                                                          
 Actual Data For Five Year Forecast                             1 of  1 
  PF4 Execute         F10 Reset                                                 
  F7  Help            F11 Save/Recall                                           
  F8  Exit                                                                      
  F9  Cancel                                                
 
***help for “source of projected amounts…” 

A = Use the July 1st Cash Balance, FYTD Expendable and FYTD 
Receivable values from the USAS accounts.                                      
S = Use the SM1 estimate amounts for the current fiscal year         
actuals  
B = Leave the amounts blank (zero)                      

 
 
Output file(s):  
  
       USASFF.TXT 
       USASFF.CSV 
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Importing Data From  
USASFF 

    

 If you choose to import data using USASFF.  You should 
follow these basic steps: 
 
1) Run USASFF and review the report.  The text report 
includes the detail budget/revenue accounts which are 
included in each line. 
 
2) Download the CSV file (USASFF.CSV) produced by 
USASFF to your PC or Mac.  Your OECN DAS personnel 
may need to help you with this step.  (See below) 
 

Tip 
 
Be sure to download the 
CSV file in the correct 
mode. 
 
For example, if using FTP 
or Kermit, download the 
CSV file in "ASCII" mode. 

 

 
Downloading Files 

 
The following will provide you with the necessary steps to download files to your 
pc. 
 
After you have created the CSV file (instructions above)…do the 
following… 
 
Make sure you’re at your Hi! prompt… 
 
1. In the upper left hand corner of your Reflections screen, click on File 
2. From the File menu, click on Transfer 
3. A file transfer box will appear and you will need to select the following 

options: 
a.) Click on the “Show Host Files” box.  It will do a search of your 

directory on our system and then will produce a listing of the files in 
there ready for transfer in the upper right hand portion of the 
screen. 

b.) Scroll down through the listing and select the USASFF.CSV file by 
clicking on it. 

c.) In the drive selection box (lower left hand corner) Click on C: if not 
already selected or the drive on your pc where you want the 
transferred CSV file to be located. 

d.) In the local directories box (just above the drive selection box) 
select the directory pathname where the CSV file is to be saved on 
your pc. 
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e.) In the center of the screen select the following options: 
1) Protocol  = WRQ/Reflections 
2) Transfer Type = ASCII 
3) If file exists? = Overwrite 

f.) At the top center of the screen, click on the arrow box pointing to 
the left.  This will start the file transfer of the file you selected from 
your account on our system to your pc. 

g.) A progression box will appear to show the transfer in progress, 
once that goes away, the file transfer is completed and you may 
click on Close to close the file transfer box. 

 
Note:  Once the file has been successfully transferred, open it by locating it 
on your pc and double clicking on the file.   
 

  3) You should now have both this forecast spreadsheet and the CSV file open in 
Excel.  Now do the following: 
 
a.) Switch to the CSV file and select the entire worksheet.  The easiest way to do 
this is to click on the upper left corner of the sheet (in the blank corner adjacent to 
the column A and row 1 labels.)   Alternatively, you may click-drag from cell A1 
through F56 to select the appropriate cells. 
 
b.) On the menu bar, choose Edit->Copy.  A dashed box should appear around the 
copied cells. 
 
c.) Switch back to the 'Data' sheet in the Forecast workbook and click on cell A1. 
 
d.) From the menu bar, choose Edit->Paste.  The data from the CSV file should 
now appear in the 'Data' sheet. 
 

 4) If you completed the above steps successfully the data from the CSV file should 
be in the 'Data' sheet of this workbook.  Now switch to the 'Forecast' sheet.  You 
should see the values from the 'Data' sheet have been automatically placed in the 
correct locations of the Forecast.   
 
If you see any error values (e.g. #VALUE, #N/A, etc) then something went wrong 
during the import.  If this occurs, it is recommended that you start over with a fresh 
copy of the spreadsheet. (If you have already done a significant amount work in the 
forecast and don't want to start over, see "Correcting Common Problems" below. 
 
After the data is loaded, you can proceed with completing the forecast (see below). 
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Entering or Correcting 
Data Manually 

    

  
If you choose not use the data from USASFF, or you are not a state software user, 
then you must enter the actual values manually.  You may do this by simply 
switching to the 'Forecast' sheet and enter the values in the appropriate row and 
column.  There will be formulas in the cells. You may simply type the numeric 
values over the fo rmulas.  (Note: Once this is done, you may not load the USASFF 
CSV file later.  If you type over the formulas then the link between the 'Forecast' 
and 'Data' sheets will be broken.) 
 
Even if you loaded the data from USASFF, you will probably need to make manual 
changes to correct errors or reclassify revenues or expenditures.  In this case,  you 
have two choices.  You may correct the values in the 'Data' sheet or you can 
replace the formulas on the 'Forecast' sheet as described above.  If you make the 
changes in the 'Data' sheet, then the values will be automatically updated in the 
'Forecast' sheet. 
 
When entering manual data, you should not enter any values in lines which contain 
subtotals (i.e., cells that contain a SUM formula).  The subtotals will be adjusted 
automatically when you change the detailed data. 
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Completing the Forecast     

 After importing or entering the actual values, you must complete the forecast.  
USASFF cannot supply all of the information necessary so you must enter the 
appropriate values in the 'Forecast' sheet.   For example, you must enter values for 
'New Levies', and 'Reserve' balances.  It is left to the Treasurer to determine which 
values are needed to produce a valid and complete forecast. 
 
The spreadsheet does not attempt to calculate values for the forecasted columns of 
the forecast.   You may either calculate the numbers manually and enter the values in 
the appropriate column and row, or you devise your own formulas for the forecasted 
amounts. 

 
Correcting Common 
Problems 

    

 
 

  
Running out of memory 
 
If Excel complains that it is 'out of memory', it's likely that this "Instructions" 
sheet is too large.  Print the "Instructions" sheet and then delete the 
instructions (right click on the 'Instructions' tab and choose Delete). 
 

  Damaged Formula 
 
If you accidentally delete or type over a formula, don't panic. The formulas in 
this spreadsheet were constructed to be easy to fix.  A given formula on the 
spreadsheet can be recreated very easily.  Simply select a formula from a 
similar cell that is still working and choose Edit->Copy.  Then move to the cell 
with the damaged formula and choose Edit->Paste Special.  In the dialog box, 
choose  the 'Formulas' radio button and click OK. 
 
Excel will automatically adjust the formula you copied to have the correct 
references. 
 

  Other Problems 
 
If you manage to damage your copy of the spreadsheet in other way, you don't 
necessarily have to start over.  Your local DA Site may be able to help you 
recover the spreadsheet.  Alternatively, you can contact the SSDT for 
assistance.   The best way to do this is via the OECN Forums web site (see 
link in first "Tip").   We may ask you to upload your spreadsheet to the forum so 
that we can look at it or repair it for you.  
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Exporting for use with EMIS 
(FFIMPORT) 

   

 After you have completed the forecast, you must provide 
the information to the EMIS system.  You may either 
manually re-enter the data from this spreadsheet, or you 
may use the EMIS FFIMPORT program to import the 
results of this spreadsheet. 
 
Note:  Save the entire workbook by clicking on the 
Save button before continuing to save it in the Excel 
format. 
 
To prepare this spreadsheet for importing into EMIS, 
switch to the 'Forecast' sheet and choose File->Save As...  
Give the file a different name and in the 'Save as Type' 
field, choose 'CSV (comma delimited)'.  
 
The resulting file must then be uploaded to the DAS 
computer system for loading into EMIS using FFIMPORT.  
Your DAS personnel may need to help you with the 
uploading process. (see next section) 
 
Important: Be certain that you extract the 'Forecast' sheet 
and not the 'Percentage View' or 'Summary View'.  Only 
the 'Forecast' sheet has all the information required by 
EMIS. 

Note: 
 
The spreadsheet is 
compatible with the 
default options of 
FFIMPORT.  You do not 
need to enter any special 
values in FFIMPORT 
unless you have added or 
removed columns from 
the spreadsheet. 

 
 

Uploading the Forecast 
 
The following will provide you with the necessary steps to upload files from your 
pc into the EMIS  database for reporting. 
 
After you have saved the Forecast portion of the five-year forecast as a 
CSV (comma delimited) file (instructions above)…do the following… 
 
1. In the upper left hand corner of your Reflections screen, click on File 
2. From the File menu, click on Transfer 
3. A file transfer box will appear and you will need to select the following options: 

a.) In the drive selection box (lower left hand corner) Click on C: if not 
already selected or the drive on your pc where the file is located. 

b.) In the local directories box (just above the drive selection box) 
select the directory pathname where the file was saved on your pc. 
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c.) In the local filenames box find the spreadsheet filename and click 
once on it to select it.  It will appear in the box. 

d.) In the center of the screen select the following options: 
1) Protocol  = WRQ/Reflections 
2) Transfer Type = ASCII 
3) If file exists? = Overwrite 

e.) Top center of the screen, click on the arrow box pointing to the 
right.  This will start the file transfer of the file you selected from 
your pc to your account on our system. 

f.) A progression box will appear to show the transfer in progress, 
once that goes away, the file transfer is completed and you may 
click on Close to close the file transfer box. 

 
 
Other 
Suggestions 

    

     
 
 
This spreadsheet was formatted to print acceptably on a laser or inkjet printer.  If 
you find that the forecast does not print well on a single page with your printer, then 
you should use File->Page Setup and change the "Fit to" parameters 
appropriately.  Most likely, you will want to print one page wide and two pages tall. 
 
If the shading does not print well, or just annoys you, you can remove it easily by 
selecting the entire forecast sheet and choosing Format->Cells.  Select the 
Patterns tab and then 'No color".  This will remove the fill colors from the entire 
spreadsheet. 

 
 
 

Notes to the Five-Year Forecast 
 

In addition to the forecast, each district is required to report Notes to the financial 
forecast as well.  Normally, you would create this in Microsoft Word, 
WordPerfect, or some other word processing program of your choice.  Once the 
file is created and saved in your word processing software, do the following: 

a.) Open the file by locating it and double clicking it. 
b.) Click on File and then Save As… 
c.) Click to select the location of where the new file is to be stored on 

your pc 
d.) Enter a file name 
e.) Click on Text Only for the save type in the dropdown box. 
f.) Click on Save. 
g.) Upload the file from your pc to the system using the instructions on 

the next page. 
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Note:  Alternatively, if you wish to skip the process above, you can do the 
following: 

a.) Open the Notes file that you created on your pc 
b.) Drag the entire document to highlight  
c.) Click on Edit…Copy  
d.) Go to your Reflections screen (where you are logged into our 

system AND have the proper “P” database selected), select 
EMSFCN, and then EMSFN/EDIT and enter the data by clicking on 
Edit and then Paste.  (Be sure that you are in the correct database) 

 
 

Uploading the Notes File 
 

The following will provide you with the necessary steps to upload files from your 
pc into the EMIS database for reporting. 
 
After you have saved the Notes to the five-year forecast as a text-only file 
(instructions above)…do the following… 
 
4. In the upper left hand corner of your Reflections screen, click on File 
5. From the File menu, click on Transfer 
6. A file transfer box will appear and you will select the following options: 

a.) In the drive selection box (lower left hand corner) Click on C: if not 
already selected or the drive on your pc where the TXT file is 
located. 

b.) In the local directories box (just above the drive selection box) 
select the directory pathname where the TXT file was saved on 
your pc. 

c.) In the local filenames box find the spreadsheet filename (TXT file) 
and click once on it to select it.  It will appear in the box. 

d.) In the center of the screen select the following options: 
1) Protocol  = WRQ/Reflections 
2) Transfer Type = ASCII 
3) If file exists? = Overwrite 

e.) Top center of the screen, click on the arrow box pointing to the 
right.  This will start the file transfer of the file you selected from 
your pc to your account on our system. 

f.) A progression box will appear to show the transfer in progress, 
once that goes away, the file transfer is completed and you may 
click on Close to close the file transfer box. 
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Getting the Data into EMIS 
 

Note:  You MUST have accomplished the two steps above involving getting 
both the CSV forecast file AND the notes TXT file uploaded to your account 
on our system.  You can’t continue with these instructions unless you have 
done so. 
 
Go into the menu system and select EMIS, EMIS_SEL, and then select the P 
database for the current FY EMIS financial forecast database.  This is where we 
will load all of the data AND it is also the place where you will come back to make 
any future corrections. 
 
Loading the forecast into the EMIS database: 
 
To load the CSV file that you uploaded to your account into the forecast 
database, you will run the FFIMPORT program.  To do so, type FFIMPORT at 
your menu prompt.  The following is a screen example of the FFIMPORT 
program: 
 
Import Five Year Financial Forecast                      
 
Import File                       MYFORE.CSV (Enter the CSV filename here)                   
File type                         CSV        
 
 For each field in the forecast, indicate which column of 
 your import file contains the field.  If using the spreadsheet 
 provided by the SSDT, use the default values.  If using 
 another spreadsheet, you must indicate the correct column(s) for 
 each field. 
 
    Forecast Fields               Column Number(s) 
    Line Number                   1     
    Prior Year Actual             3,4,5      
    Average Change                6     
    Forecasted Year Amounts       7,8,9,10,11          
 
 
                                                                                

                                                                        
1 of  1 

  PF4 Execute         F10 Reset                                                 
  F7  Help            F11 Save/Recall                                           
  F8  Exit                                                                      
  F9  Cancel                                                                    
 
To check the data, select EMSFCN, and then EMSFF, or run the FORECAST 
report from the EMIS_RPT option of the menu. 
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Loading the Notes into the EMIS forecast database: 
 
To load the TXT notes file that you uploaded to your account on our system, do 
the following: 
 

1.) Select the P database for the FY you are working on 
2.) Type EMSFCN at your menu prompt. 
3.) Select the EMSFN option. 
4.) Select the Import option and the following window will appear: 

 
 
             R,,,,,Enter Input Filename                    ,,,,,T 
             .                                                  . 
             .File name:                                        . 
             .                                                  . 
             .                                                  . 
             . Supercede    Append    Cancel                    . 
             F,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,G 

 
5.) Enter the name of the file as you called it when you uploaded it to 

your account and select “Supercede” to overwrite what’s in there. 
6.) To view the notes as they are in the database, you may select the 

Edit option.  You may also make changes while in the Edit mode if 
necessary.  When finished, hit the Do key and type either EXIT to 
exit and save changes or QUIT to exit without saving changes. 

 
 

Finished??? 
 

Check to make sure that your data has been properly loaded by doing the 
following: 
 

1.) Go into MENU and select the forecast database you’re working on. 
2.) To check the forecast data…You can run the Forecast Report from the 

menu by typing FORECAST or type EMSFCN and then select EMSFF 
to view your forecast data.  Check the data line by line compared to 
your Forecast to make sure the data is correct.  You can also hit the 
F20 key while in that screen to validate the data.  Any errors in lines or 
subtotals will appear.  (If there are errors, it will give you an option to 
Acknowledge or Fix) 

3.) To check the Notes… Type EMSFCN and then EMSFN.  To view the 
notes select the Edit option.  You may also make changes while in the 
Edit mode if necessary.  When finished, hit the Do key and type either 
EXIT to exit and save changes or QUIT to exit without saving changes. 

4.) Request a validation of your forecast data.  Once your data is error 
free, we will submit it to state for you. 
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Resubmitting Your Forecast Data 
 

At some point, your district may need to resubmit your forecast data due to errors 
or variances.  To do so, you can follow one of two methods…whichever is 
easiest for you.   
 
Method 1:  
 
Follow the instructions in the this booklet as you did when creating the original 
forecast submission by making your changes in the actual forecast and notes, 
saving those files as CSV and TXT files, uploading to the system, and importing 
both files into the EMIS forecast database.  When finished, send FSTAFF an 
email requesting validation and submission of your forecast data. 
 
Method 2: 
 
Instead of going through the entire process again of correcting, uploading, 
importing, etc, you can select the forecast database to make corrections or 
changes to your data.  Go to EMSFCN and select EMSFF to correct the forecast 
data directly by selecting the line number and then modify/add/delete that line.  
Be sure to use the F20 key after the changes to validate the totals. To change 
the notes, select EMSFN/EDIT and make changes to your notes to the forecast. 
When finished, send FSTAFF an email requesting validation and submission of 
your forecast data. 


